Purview Sync Application registration issues troubleshooting
In this topic, you can find solutions to common issues when registering the Purview Sync application with Microsoft.
Table of Contents (Advanced Access)
Use this table of contents to navigate Purview Sync documentation during the Advanced Access phase.
- Purview Sync (Advanced Access)
- Install Purview Sync (Advanced Access)
- Register Purview Sync with Azure (Advanced Access)
- Configure Purview Sync (Advanced Access)
- Importing data (Advanced Access)
- Data transformation (Advanced Access)
Common issues
Click on any of the scenarios to see the cause of the issue and the resolution.
Cause
You have not configured the redirect URI. On the Authentication page, in the section Single-page application, the Redirect URIs does not have a configured URI.
Fix
To resolve this issue:
- Copy the redirect URI mentioned in the error message.
- Paste the redirect URI to Single-page application.
You can also create a URI. For more information, see Authentication.
You can now sign into Microsoft.
Cause
User Client Secret is wrong or expired.
Fix
Check that you provided Client Secret that is not expired.
To update the client secret:
- In RelativityOne, navigate to Purview Sync > Configuration.
- If secret is not expired, click Edit Purview Sync configuration.
- Update the Client Secret field.
- Click Save.
For more information, see Creating a client secret.
Cause
Missing Global Admin assigned role. 
Fix
To update the missing Global Admin role:
- In Azure, navigate to Users.
- Search for your user.
- Go to Assigned roles and click link next to the text.
- Check if you have Global Administrator role.
It might be that you will see information's about Eligible role assignment. In that case, please contact your Azure administrator.
Cause
There is an issue with wrong character in URI. Open Developer tools > Console. Repeat reproduction step to check what you logged in. The console window can look like the following image:
Fix
To resolve this issue:
- Navigate to Purview Sync > Configuration.
- Verify if there is no white spaces at the beginning and end of the URI’s.

- Then navigate to App Registration > Find your application > Authentication.
- Verify if Web Redirect URIs and Single-page application Redirect URIs contains correct URLs and verify if there are any spaces at the end or beginning of URI.
- Web Redirect URIs should contain {Company URI}/purview-sync-services/api/v1/AppConfiguration/auth-response.
- Single-page application Redirect URIs should contain {Company URI}/Relativity/CustomPages/f444a06a-617c-430b-90b2-a112e834b826/ms-auth-popup-redirect.html.




